Minecraft | Which Java Version should I use? Print

  • Minecraft Which Java Version should I use?, Which Java Version should I use?, Minecraft Java Version, Minecraft, Java Version, Minecraft Version
  • 4

Which Java Version should I use?

Without prior knowledge, it's difficult to determine which version of Java is required for a specific Minecraft version. The table below shows which Java version is required for which Minecraft version.

Our servers by default run the latest Java version for the latest Minecraft version, so if you change the version of Minecraft your server is running, you will need to change the Java Version as well (the process is covered at the bottom of the guide)

Minecraft Version Recommended Java Version
1.8 to 1.11 Java 8
1.12 to 1.16.4 Java 11
1.16.5 Java 16
1.17.1-1.19.2 Java 17
1.20+ Java 21


How to change Java version

  1. Stop your server.
  2. Backup all data you want to keep.
  3. Click the "Change Java version" button in your game panel.
  4. Select the Java version that corresponds to the version of Minecraft your server will use - check the table above if unsure.
  5. Press "Execute" in the top left.
  6. Wait for the process to complete, it will tell you when it's done.
  7. Startup your server, it should work but if it doesn't contact us via a support ticket and we'll get it working for you.

Looking for a game server host known for brilliant 24/7 customer support and quality hardware?

Try a Pingperfect Minecraft server today! https://pingperfect.com/gameservers/minecraft-game-server-hosting-rental.php


Was this answer helpful?

« Back